Для этого необходимо лишь немного знаний в области создания формул и форматирования ячеек книги Excel



Работа добавлена на сайт TXTRef.ru: 2019-04-07

Cоздание календаря в программе Microsoft Excel

Предлагаем вам создать универсальный календарь самостоятельно. Для этого необходимо лишь немного знаний в области создания формул и форматирования ячеек книги Excel.

Обычно календарная сетка не что иное, как особым образом отформатированная таблица данных. Пусть в заголовках столбцов отображаются полные или сокращенные названия дней недели (получить их можно при помощи метода протягивания). Количество дней в любом из месяцев ограничено, поэтому будет достаточно шести дополнительных строк для размещения дат всех дней указанного месяца любого года. Однако следует учесть, что каждая дата должна располагаться в столбце, обозначающий день недели, на который она выпадает. В Excel существует немало полезных функций по работе с датой и временем.

Пошаговая технология создание календаря в программе Excel 

  1.  На первом листе в ячейку А1 введите номер месяца, например, 1
  2.  Создать на втором  листе вспомогательную таблицу размером 6 строк на 7 столбцов, в которой нужно слева направо разместить цифры от 1 до 42.
  3.  На втором листе в ячейку А1 ввести номер года (например, 2013), в ячейку В1 –  формулу ='Лист'!A1

  1.  Под таблицей создаем вторую вспомогательную таблицу этого же размера, поместив в каждую ячейку формулу

=Нм + ДАТА(Гд,Мс,1) - ДЕНЬНЕД(ДАТА(Гд,Мс,1);2)

Поясним смысл формулы:

ДЕНЬНЕД – встроенная функция Excel, которая возвращает для указанной даты её день недели,

Нм –относительная ссылка на 1-ую ячейку 1-ой вспомогательной таблицы,

ДАТА – функция возвращающая дату, которая выпадает на первый день указанного месяца выбранного года. Её аргументами являются: Гд - ссылка на ячейку где находится год, Мс - ссылка на ячейку с числом месяца.

  1.  В таблицу на первом листе:
    1.  в ячейки А2:G2 ввести названия дней недели.
    2.  в ячейки А3:G7 для создания календарной сетки заносятся формулы, которые не отображают даты, принадлежащие предыдущему и следующему месяцу:

=ЕСЛИ(МЕСЯЦ(Дт) = Мс; Дт;"")

где: МЕСЯЦ – встроенная функция Excel, которая возвращает месяц из указанной даты,

Мс - ссылка на ячейку месяца,

Дт - ссылка на ячейку 2-ой вспомогательной таблицы (в которой вычислены даты месяца)

Для нашего примера формула первой ячейки второй вспомогательной таблицы имеет следующий вид:

=A3 + ДАТА($A$1;$B$1;1) - ДЕНЬНЕД(ДАТА($A$1;$B$1;1);2)

Формула ячейки А3 основной таблицы в нашем примере имеет вид:

=ЕСЛИ(МЕСЯЦ(Лист2!A12) = Лист2!$B$1; Лист2!A12;"")

  1.  Формат ячеек таблицы календарной сетки задаем таким образом, чтобы отображались только числа месяца. Для этого в диалоговом окне "Формат ячейки" на вкладке "Число" выбираем пункт "Все форматы", а в строке справа набираем символ Д.

Как видите все достаточно просто и легко, если знаешь как работать с формулами в Excel! Наш календаря можно легко преобразовать в настольный заменив конкретный год и месяц на формулы для их вычисления из текущей даты. Также меняя всего две цифры можно создать все 12 месяцев. И скопировать их в Microsoft Word или оформить их аккуратно на одном из чистых листов книги Excel.

Примечание. Для добавления формул в другие ячейки таблиц используем метод протягивания (копирования формул).

Доработайте календарь, введя в ячейки листа 1 формулы, как на рисунке ниже. После такой доработки вы будете изменять номер года и номер месяца. Все остальное сделает за вас Excel/

Другие работы

і. Конституція України про права та свободи г...


Порядок участі адвоката у цивільному судочинстві. Порядок участі адвоката у кримінальному судочинстві. Порядок участі адвоката у справах про адм...

Подробнее ...

Краткий исторический обзор изучения проблем...


Краткий исторический обзор изучения проблемы способностей Экспериментальная психология родилась в середине XIX века. Не была исключением и психо...

Подробнее ...

РЕФЕРАТ з теми- Використання аналітичних орга...


Застосування органічних реагентів у рідинній хроматографії для поділу вуглеводнів. Застосування органічних реагентів у рідинній хроматографії для...

Подробнее ...

Философия на 20122013 уч


Предмет философии. Сущность и функции философии ее место и роль в культуре. Основные направления в философии: материализм и идеализм их виды. По...

Подробнее ...